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Bagaimana Menggunakan 
Google Slides  
 

Ketika mebaha tentang presentasi, PowerPoint dan Keynote mendapatkan 

seluruh sorotan. Google Docs sering kali disebutkan sebagai alternatif dari 

Word, serta ada banyak sekali tios di luar sana yang tentang cara unik 

menggunakan Google Sheets, tetapi Google Slides jarang sekali disebutkan. 

Itu sangat disayangkan sebab Google Slide sebenarnya alat presentasi yang 

sangat bagus dan tersedia secara gratis. 

Anda mungkin berpikir, “Apa itu Google Slides?” Pada tutorial Google Slides 

kali ini kami menjawab pertanyaan tersebut, saya akan mengajarkan Anda 

bagaimana cara membuat presentasi pada Google Slides, serta 

memperkenalkan Anda pada keuntungan menggunakan Google Slides 

sebagai desktop standar aplikasi presentasi Anda. 

 

Sekarang mari melompat ke dalam tutorial ini untuk mempelajari lebih jauh 

apakah Google Slide itu dan bagaimana memulai menggunakannya. 

Langkah 1. Memulai 

Google Slides adalah aplikasi presentasi andalan Google yang hidup di dalam 

mesin pencari sebagai bagian dari Google Docs. Dan 100% gratis—satu-

satunya syarat untuk menggunakannya adalah untuk memiliki akun Google. 

Karena merupakan aplikasi web gratis, maka Google Slide tidak memiliki fitur 

selengkap aplikasi desktop seperti Microsoft PowerPoint dan Keynote. 

https://www.google.com/slides/about/
https://docs.google.com/
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Bagaimanapun, Google Slides dibuat untuk menanggulangi kekurangan fitur 

estetis dengan mengutamakan fitur kolaborasi yang kuat – bahkan yang 

terbaik.  

Kurva belajar untuk Google Slides juga jauh lebih rendah daripada aplikasi 

desktop fitur penuh dikarenakan Google Slides hanya menyediakan fitur yang 

paling esensial dan menghilangkan kebanyakan hal-hal tidak penting.  

Mari kita lihat bagaimana Google Slides membuat presntasi Anda, karena ini 

merupakan pilihan software presentasi online terbaik untuk digunakan. 

Langkah 2. Membuat Presentasi Baru 

Setelah masuk ke dalam Google Account, pergi ke Google Drive. Di sana, 

buat sebuah presentasi dengan mengklik New > Google Slides. Kamu akan 

diarahkan ke halaman baru dengan sebuah presentasi kosong. 

 

 

Membuat sebuah presentasi baru. 

 

1. Memformat Sebuah Presentasi 

http://drive.google.com/
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Langkah pertama dalam membuat presentasi baru adalah mengatur 

bagaimana ia akan terlihat, sehingga mari lihat kolom samping berlabel 

Themes yang muncul ketika membuat presentasi. 

Google Slides hadir dengan berbagai themes yang berbeda untuk slide. 

Kebanyakan dari tema ini secara estetis tidak semenarik yang terdapat pada 

aplikasi desktop—terutama yang terdapat pada versi terbaru Keynote—tetapi 

Google Slides cukup fungsional dan memiliki pilihan yang bagus dari berbagai 

jenis tema dasar preentasi.   

Kolom Themes muncul pada bagian kanan dari presentasi kosong Anda. 

Gunakan scroll bar untuk berpindah menuju berbagai tema lainnya yang 

tersedia. 

Beberapa 

theme default Google Slides. 

 

Jika tidak ada tema dasar Google Slides yang sesuai kebutuhan Anda, Anda 

memiliki banyak opsi tambahan. 
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Anda dapat menemukan banyak sekali tema Google Slides baru pada 

GraphicRiver, yang dibuat oleh para desainer profesional. Atau, jelajahi 

koleksi kami dari tema presentasi terlaris untuk menemukan tema yang 

sedang trend, seperti beberapa yang terlaris di bawah ini:  

Template Google Slides terbaik, tersedia untuk dibeli pada GraphicRiver. 

Bahkan, Anda dapat mengunggah tema original pada Google Slides dengan 

mengklik tombol Import theme pada launcher. Jendela Import 

theme muncul. Anda dapat menggunakan tema dari presentasi sebelumnya, 

tarik sebuah tema ke jendela Import Theme dari komputer Anda, atau pilih 

Select kemudian pilih sebuah file dari komputer Anda. 

https://graphicriver.net/category/presentation-templates/google-slides
https://graphicriver.net/popular_item/by_category?category=presentation-templates/google-slides
https://graphicriver.net/search?utf8=%E2%9C%93&referrer=search&view=grid&sort=sales&category=presentation-templates%2Fgoogle-slides
https://graphicriver.net/popular_item/by_category?category=presentation-templates/google-slides
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Anda dapat mengunggah tema original pada Google Slides menggunakan 

jendela Import Theme. 

Google mendukung unggahan hingga 50MB dalam format .ppt, .pptx, .pptm, 

.ppsx, .pot, .odp, dan format Google Slides. 

Setelah memilih theme, tentukan aspect ratio pada slide. Dari File > Page 

setup, ada pilihan untuk Standard 4:3, Widescreen 16:9, Widescreen 

16:10, dan Custom.  

Pilih aspect ratio yang paling cocok dengan layar yang akan kamu gunakan 

ketika mempresentasikan slideshow. Umumnya, aspek rasio Standard Google 

Slide adalah yang terbaik jika presentasi ditampilkan proyektor, dan aspek 

rasio Widescreen paling sesuai jika Anda mempresentasikannya 

menggunakan komputer atau TV layar lebar. 
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Pilih 

ukuran slide yang paling sesuai dengan mode presentasi Anda. 

 

Klik OK ketika Anda telah menentukan tema dan aspek rasio presentasi 

Anda. Untuk tutorial Google Slides ini, saya akan menggunakan tema 

Paperback dan aspek rasio 16:9. 

Catatan: Tema dan aspek rasio dapat diubah nantinya dengan mengklik 

Slide > Change Theme. 

Saya sarankan untuk mengubah nama presentasi Anda ketika Anda telah 

menentukan tema awal. Untuk melakukannya, klik pada presentasi Untitled 

pada sudut kiri atas pada layar, dan ketik sebuah nama baru. 

Menamai ulang presentasi. 

 

Langkah 3. Menavigasi Google Slides 

Mari kita lihat cara menggunakan tool pada Google Slide. Google Slides 

bekerja seperti aplikasi presentasi desktop. Kolom di sebelah kanan Google 
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Slides menampilkan slide yang Anda buat, dan badan layar yang tampil 

adalah slide yang sedang Anda kerjakan. 

Antarmuka Google Slides mirip seperti aplikasi presentasi desktop. 

 

Untuk tujuan kita, slide pertama akan menjadi slide judul. Untuk 

menambahkan judul, klik di mana di katakan Anda dapat mengetiknya, 

kemudian ketiklah judulnya. Anda juga dapat menambahkan subjudul atau 

membiarkannya kosong. Kotak yang dibiarkan kosong tidak akan tertampil 

pada saat presentasi akhir, sehingga Anda tidak perlu menghapus elemen 

ekstra. 

Tambahkan Judul pada Presentasi Google Slides Anda 

 

Ketika memilih teks, opsi baru kan muncul pada toolbar di atas. Ikon pada 

bagian tengah toolbar mengizinkan Anda untuk menyunting tampilan kotak 

teks, seperti warna latar belakang dan pembatas tepi. Ikon pada bagian 

kanan mengizinkan Anda untuk menyunting tampilan teks itu sendiri, seperti 

jenis huruf, ukuran huruf, warna, dan model seperti tebal, bergaris bawah, dan 

miring. 
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1. Fungsi yang menyunting tampilan kotak teks. 2. Fungsi yang menyunting 

tampilan teks. 

 

1. Menambahkan dan Menghapus Slide 

Ketika Anda telah suka dengan tampilan judul slide Anda, Anda dapat 

menambahkan lebih banyak pada presentasi Anda. Untuk menambahkan 

slide, klik tobol + pada bagian kiri atas dari layar. Hal ini akan menampilkan 

sebuah slide baru dengan tata letak Judul dan Badan. 

Tekan “+” untuk menambahkan slide baru. 

Sebaliknya, slide dapat juga dihapus dengan memilih slide yang akan dihapus 

dan mengklik Edit > Delete, atau dengan meng-klik kanan pada thumbnail 

slide pada kolom samping kemudian klik Delete Slide, atau lebih mudah lagi 

dengan menekan tombol Delete ketika telah memilih thumbnail slide.  

2. Menambahkan Teks 

Slide baru ini akan menjadi slide informasi. Tambahkan judul yang relevan 

dengan informasi yang Anda masukkan pada slide Anda. 

Untuk badak teks, Anda mungkin ingin melakukan beberapa pengatran 

tambahan. Ini merupakan presentasi kan, sehingga paragraph yang panjang 

akan mengurangi keefektifan badan slide. Klik kotak teks badan slide untuk 

memunculkan opsi teks, kemudian klik More untuk melihat opsi teks. Dengan 

hal ini Anda dapat membuat daftar-daftar poin. 

Buatlah daftar poin dengan meng-klik More > Bulleted List. 

Sekarang, ketika badan teks telah memiliki format yang tepat, tambahkan 

informasi pada slide. Jika Anda blum melakukan riset tentang topik 

presentasinya, Google Slides memiliki alat riset in-app (dalam aplikasi) yang 

dapat diakses via Tools > Explore. 



9 

Kolom Expore mengizinkan Anda untuk melakukan pencarian informasi dari 

dalam aplikasi. Anda juga dapat memfilter pencarian untuk memasukkan 

materi hanya dari Web, Gambar, atau Google Drive. Menggunakan See All 

Result pada link Google pada bagian bawah kolom akan membawa Anda 

pada jendela pencarian Google keseluruhan. Anda dapat melakukan pratinjau 

link tersebut langsung dari kolom tepi dan memasukkan link langsung pada 

presentasi dari kolom tepi tersebut. 

Dapatkan infomrasi topik dari dalam aplikasi menggunakan kolom tepi 

Explore. 

 

Tambahkan informasi yang kamu inginkan untuk ditampilkan pada slide. 

Catatan presentasi dapat juga ditambahkan pada kotak yang terdapat di 

bawah untuk mengakses informasi tambahan tanpa harus mengacaukan slide 

Anda. 

3. Menambahkan Media 

Slide berikutnya akan menjadi slide dengan elemen media. Karena media 

akan ditambahkan pada slide ini, tata letak default tidak akan cocok. Untuk 

slide ini, klik tombol panah di sebelah tombol +, pilih tata letak yang berbeda 

untuk slidenya, lebih disarankan salah satu dari baris terbawah. Saya akan 

menggunakan Caption. 

Pilih sebuah layout slide. 

 

Klik tombol panah di sebelah “+” untuk melihat pilihan tata letak tambahan. 

Tip: Tata letak dapat diubah nanti menggunakan tombol Layout pada toolbar. 

Mari kita lihat bagaimana menggunakan Google Slides untuk menambahkan 

gambar pada presentasimu. Untuk menambahkan gambar, klik tombol 

Image pada toolbar, atau pergi ke Insert > Image. 



10 

Ada beberapa cara untuk menambahkan gambar pada presentasimu. Anda 

dapat mengunggah gambar Anda sendiri yang diambil dari hard drive Anda, 

akun Google+ Anda, atau Google Drive; Anda dapat mengambil gambar 

menggunakan webcam; atau Anda dapat mencari via Google, arsip foto 

majalah LIFE, atau stok foto pada panel Insert Image. 

Pilih sebuah sumber gambar dari panel Insert image. 

Catatan: Ketika mengunduh gambar, perhatikan larangan properti intelektual. 

Misalnya, di bawah pencarian Stock Image, ada kalimat “Hasil yang 

ditampilkan tersedia untuk penggunaan personal atau komersial hanya pada 

Google Drive, dan tidak boleh didistribusikan kembali secara independen atau 

dijual” yang ditampilkan. 

Ketika Anda telah menemukan gambar yang Anda sukai, klik gambar tersebut 

dan tekan Select (dari arsip atau stok gambar) atau Open (dari opsi Upload) 

untuk menyisipkan gambar tersebut ke dalam presentasi. Di sana, gambar 

dapat dikecilkan ukurannya dan diputar sesukamu.  

Gambar dapat dengan mudah diubah ukurannya menggunakan jangkar yang 

terdapat di tepi foto. 

 

4. Menambahkan Animasi 

Jika Anda berniat membumbui presentasi Anda sedikit, Google Slides 

menawarkan beberapa animasi berbeda yang dapat Anda gunakan untuk 

elemen slide dan tansisi antar slide.  

Berikut cara menggunakan Google Slides untuk menambahkan animasi pada 

presentasimu. Tambahkan transisi dengan mengklik tombol Transition pada 

toolbar. Sebuah kolom samping Animasi akan muncul, dan dari sana Anda 

dapat mengatur animasi pada presentasi Anda. 
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Menu Slide mengendalikan animasi antar slide. Ada enam pilihan transisi 

yang tersedia; pilih salah satu dari menu drop-down. Anda kemudian dapat 

memilih kecepatan transisi yang terjadi menggunakan slider Slow-Fast di 

bawah menu menurun. Slider akan menampilkan panjang transisi seperti 

yang telah Anda atur; transisi dapat berlangsung antara nol hingga lima detik. 

Klik Transition untuk menambahkan transisi antar slide. 

 

Tip: Terapkan transisi antar semua slide dengan meng-klik tombol Apply to 

All Slides pada Animasi di kolom samping. 

Obyek pada slide juga dapat menggunakan animasi. Pilih sebuah objek pada 

slide dengan mengklik pada objek tersebut, kemudian tekan Select sebuah 

objek untuk dibuat beranimasi pada Animasi di kolom samping. 

Klik Select an Object untuk menganimasikan masing-masing objek. 

 

Pilih gaya animasi dari menu drop-down pertama. Menu drop-down kedua 

mengendalikan jenis animasi individual. Animasi juga dapat diatur secara 

manual dengan memilih opsi On click, atau secara otomatis mengaturnya 

dengan memilih opsi After Previous atau With Previous. Kecepatan animasi 

dikontrol menggunakan slider Slow-Fast. Kecepatan animasi dikendalikan 

oleh slider Slow-Fast. 

Animasi dapat diubah secara manual atau otomatis. 

 

Untuk melihat pratinjau animasi, tekan Play. 

•  


